firefox で Gmailにアクセスするとき、これまでは素直に開かなかった。
パスワード入力後、通常なら受信箱が開くわけだが、ほぼ真っ白の画面のままになる。
このとき、再読み込みボタンをクリックすると開いたりしてたのだが、ここ最近、それすらもうまくいかなくなっていた。それでも何度かやり直すと最終的には開くので、とりあえず放置していた。
さて、本日 firefoxを 3.0.7 にアップグレードした。
で、Gmailにアクセスする。
あれ、うまく開いた。
他のPCでも確認してみたら、やはり3.0.6ではうまく開かず、firefox 3.0.7 ならばうまくいくようだ。
firefox の問題だったのですね。
2009年03月06日
2009年02月26日
Windows 7 のバージョン番号
Windows Vista のバージョン番号は 6.0
これはOSに問い合わせると答えてくれる番号です。
それなら、Windows 7 ベータ のバージョン番号は7.0 ?
と思ったら、 6.1 でした。
製品版では変わるんでしょうか。
別にどーでもいい話題でした。
これはOSに問い合わせると答えてくれる番号です。
それなら、Windows 7 ベータ のバージョン番号は7.0 ?
と思ったら、 6.1 でした。
製品版では変わるんでしょうか。
別にどーでもいい話題でした。
2009年02月16日
VMware Player を Vista にインストールしてみた。
表題通り、VMware Player 2.5.1 を Windows Vista にインストールしてみたが、すんなりインストールできなかったので、ここの記事にすることにした。
インストール中に、こんなエラーがでるのだ。
エラー 1406。値 InstallPath をキー \Software\VMware, Inc\VMWare Converter Hosted に書き込めませんでした。そのキーへの十分なアクセス権を持っていることを確認するか、サポート担当者へお問い合わせください。
画像を見た方が早いかも。

このエラーが出ると、再試行や無視をしてもまた同じエラーが出るので、インストールを中止するしかない。中止をクリックすると、おもしろいことにインストールがロールバックされるようなアニメーションがでて、何もなかったことになる、らしい。(ホントか?)
ともかくエラーの原因は、レジストリへのアクセス権がないことらしい。regedit で開いてみると確かにこのキーには書き込めなくなっているようだ。しかし今は管理者権限でログオンしている。アクセス権がないといわれてもどぅしようもない。
それならば、と、今度はインストーラを管理者の権限で実行してみる。結果は同じ。
ははあん。さては、ユーザーアカウント制御(UAC)のせいだな、と思って UAC を無効にしようと思って確認したら、すでにUACは無効になっていた。(ちなみにこれは コントロールパネルの検索欄に UACと打つとわりとすぐに確認できる。)
おかしい。邪魔しているやつは何もないはずなのに。
と思いつつも UAC を有効化してみた。なに?再起動か。ああ、やだな、と思いながらVistaを再起動。起動するまでしばし待つ。そして VMWare のインストーラを起動してと....
あれ、今度はうまくいった。UACを有効化したらちゃんとインストールできたよ。
うーん。今一納得いかない。
ただ再起動が必要だっただけかもしれませんが、とりあえず、同じ問題で悩んでいる人がいたら、参考にしてください。
ちなみに VMware Server 2.0のWindows版でも同じようなエラーがでたことがあります。その時はインストールをあきらめちゃったけど、もしかしたらVistaを再起動してたらインストールできたかもしれないなあ。
インストール中に、こんなエラーがでるのだ。
エラー 1406。値 InstallPath をキー \Software\VMware, Inc\VMWare Converter Hosted に書き込めませんでした。そのキーへの十分なアクセス権を持っていることを確認するか、サポート担当者へお問い合わせください。
画像を見た方が早いかも。

このエラーが出ると、再試行や無視をしてもまた同じエラーが出るので、インストールを中止するしかない。中止をクリックすると、おもしろいことにインストールがロールバックされるようなアニメーションがでて、何もなかったことになる、らしい。(ホントか?)
ともかくエラーの原因は、レジストリへのアクセス権がないことらしい。regedit で開いてみると確かにこのキーには書き込めなくなっているようだ。しかし今は管理者権限でログオンしている。アクセス権がないといわれてもどぅしようもない。
それならば、と、今度はインストーラを管理者の権限で実行してみる。結果は同じ。
ははあん。さては、ユーザーアカウント制御(UAC)のせいだな、と思って UAC を無効にしようと思って確認したら、すでにUACは無効になっていた。(ちなみにこれは コントロールパネルの検索欄に UACと打つとわりとすぐに確認できる。)
おかしい。邪魔しているやつは何もないはずなのに。
と思いつつも UAC を有効化してみた。なに?再起動か。ああ、やだな、と思いながらVistaを再起動。起動するまでしばし待つ。そして VMWare のインストーラを起動してと....
あれ、今度はうまくいった。UACを有効化したらちゃんとインストールできたよ。
うーん。今一納得いかない。
ただ再起動が必要だっただけかもしれませんが、とりあえず、同じ問題で悩んでいる人がいたら、参考にしてください。
ちなみに VMware Server 2.0のWindows版でも同じようなエラーがでたことがあります。その時はインストールをあきらめちゃったけど、もしかしたらVistaを再起動してたらインストールできたかもしれないなあ。
2008年11月19日
grubをMBRにインストール
linux システムのハードディスクを換装する時や、パーティション構成を変更した時などは、HDDのMBR領域にgrubをインストールし直す必要がある。
そういう場合、grubそのものはすでにインストールされているわけなので、ただ単にプロンプトから、
# grub
と打ち込むと、grub のプロンプトになる。そこで以下のコマンドを打ち込む。
grub> root (hd0,1)
grub> setup (hd0)
grub> quit
root (hd0,1) はカーネルイメージが入っているパーティションの指定。数値は0から始まるので、上記は 1 台目のHDD の 2 番目のパーティションという意味。
setup (hd0) でMBRにgrub のブートイメージを書き込む。
最後に quit で終了。
そういう場合、grubそのものはすでにインストールされているわけなので、ただ単にプロンプトから、
# grub
と打ち込むと、grub のプロンプトになる。そこで以下のコマンドを打ち込む。
grub> root (hd0,1)
grub> setup (hd0)
grub> quit
root (hd0,1) はカーネルイメージが入っているパーティションの指定。数値は0から始まるので、上記は 1 台目のHDD の 2 番目のパーティションという意味。
setup (hd0) でMBRにgrub のブートイメージを書き込む。
最後に quit で終了。
2008年10月19日
フォントにリンクされた外字が印刷できない。
Windows で、フォントにリンクされた外字が、画面上では表示されているけれども、印刷ができない場合がある。それは大抵プリンタドライバの設定で、True Type フォントをどのように印刷するかを指定してあげる必要がある。
うちの場合、プリンタはオフィス向け複合機、Ricoh Imagio MP C2500。これも設定が必要。
http://www.ricoh.co.jp/support/faq/imagio/IM08056.html
ここに設定方法が書いてある。
キーワード。
「印刷品質」「ユーザー設定」「イメージデータに変換して印刷する」
まあしかし、外字をフォント毎にリンクさせていなければあまり問題にならないかも。
うちの場合、プリンタはオフィス向け複合機、Ricoh Imagio MP C2500。これも設定が必要。
http://www.ricoh.co.jp/support/faq/imagio/IM08056.html
ここに設定方法が書いてある。
キーワード。
「印刷品質」「ユーザー設定」「イメージデータに変換して印刷する」
まあしかし、外字をフォント毎にリンクさせていなければあまり問題にならないかも。
2008年07月20日
Adobe InDesign CS3:オブジェクトの拡大・縮小時の比率表示
Adobe InDesign CS3 で図形などのオブジェクトを拡大・縮小する方法にはいくつかあるが、僕が多用するのは、100% を 125% にというように数値で指定する方法。
しかし、インストールしたままだと、たとえば125%に拡大したあと、その後の表示がまた100%になってしまう。図形はたしかに拡大されるが、表示は100%と表示されてしまうのである。
これではその図形のオリジナルサイズがどれほどなのかわからなくなってしまい不便だ。これを拡大したなりのパーセンテージで表示させるには以下の環境設定が必要である。

メニューから 編集 - 環境設定 - 一般 と選ぶと上のダイアログが出てくる。ここで「拡大 / 縮小率を調整」のラジオボタンをオンにする。
これで、図形がどのくらいの比率で拡大・縮小されているのか一目瞭然になる。
InDesign は初期バージョンから使っているが、バージョンアップの度にこの設定がクリアされてしまい、その都度ヘルプで調べていた。他のバージョンでも同じようなものだろう。
しかし、このダイアログの日本語、非常にわかりづらいですな。
しかし、インストールしたままだと、たとえば125%に拡大したあと、その後の表示がまた100%になってしまう。図形はたしかに拡大されるが、表示は100%と表示されてしまうのである。
これではその図形のオリジナルサイズがどれほどなのかわからなくなってしまい不便だ。これを拡大したなりのパーセンテージで表示させるには以下の環境設定が必要である。

メニューから 編集 - 環境設定 - 一般 と選ぶと上のダイアログが出てくる。ここで「拡大 / 縮小率を調整」のラジオボタンをオンにする。
これで、図形がどのくらいの比率で拡大・縮小されているのか一目瞭然になる。
InDesign は初期バージョンから使っているが、バージョンアップの度にこの設定がクリアされてしまい、その都度ヘルプで調べていた。他のバージョンでも同じようなものだろう。
しかし、このダイアログの日本語、非常にわかりづらいですな。
2008年07月06日
どこでも AjaxIME
以前、日本語入力環境がないPCでも、ブラウザ上で日本語入力ができる、AjaxIMEを紹介しました。
いつの間にかバージョンアップして、全てのWeb上フォールで、このAjax IME が使えるようになっています。
まず、AjaxIMEにアクセスして、下の方の説明部分の、[Ajax IME]をブックマーク登録する。
AjaxIME経由で入力したいフォームページを開いて、ブックマークしたリンクにアクセスします。
数秒後にフォームが水色になれば成功。
これ、スゴイや。こんなことできるんだなあ。と感動しました。
この方法を使えば、この記事へのコメント欄でもちゃんとAjaxIMEが使えますよ。
[Ajax IME] ←これを右クリックしてブックマーク登録する。
でもいいみたいです。
いつの間にかバージョンアップして、全てのWeb上フォールで、このAjax IME が使えるようになっています。
まず、AjaxIMEにアクセスして、下の方の説明部分の、[Ajax IME]をブックマーク登録する。
AjaxIME経由で入力したいフォームページを開いて、ブックマークしたリンクにアクセスします。
数秒後にフォームが水色になれば成功。
これ、スゴイや。こんなことできるんだなあ。と感動しました。
この方法を使えば、この記事へのコメント欄でもちゃんとAjaxIMEが使えますよ。
[Ajax IME] ←これを右クリックしてブックマーク登録する。
でもいいみたいです。
2008年04月06日
kernel 2.6.20 と amanda(解決)
http://evcom.sblo.jp/article/4411674.html にて、
kernel 2.6.20 だと、amandaが他のlinuxマシンと通信できないと記述しましたが、これ、一応解決しました。
あの記事からすでに、いろいろと環境が変わってしまいましたので、整理しますと、
Fedora Core 6
kernel 2.6.22.14-72
amanda 2.5.2p1 (tarボールからインストール)
という組み合わせです。このままだとバックアップの際にデータが流れてこないのです。そこで、kernelを2.6.18-1.2798 にすると、データが流れてきます。
ですから、このカーネルで運用していました。
このほど、原因がわかりました。mtu です。ジャンボフレーム対応のNICで、mtuを7200 に設定していたのです。
思い当たることあって、mtu を標準の1500に戻してみました。
すると、新しいkernelでもちゃんとamandaは動作します。
ジャンボフレームなんて設定しても、体感ではあまり変わらないし、そのためにネットワークに支障をきたすのでは、元も子もないので、ジャンボフレームを使わないことにしようと思います。
kernel 2.6.20 だと、amandaが他のlinuxマシンと通信できないと記述しましたが、これ、一応解決しました。
あの記事からすでに、いろいろと環境が変わってしまいましたので、整理しますと、
Fedora Core 6
kernel 2.6.22.14-72
amanda 2.5.2p1 (tarボールからインストール)
という組み合わせです。このままだとバックアップの際にデータが流れてこないのです。そこで、kernelを2.6.18-1.2798 にすると、データが流れてきます。
ですから、このカーネルで運用していました。
このほど、原因がわかりました。mtu です。ジャンボフレーム対応のNICで、mtuを7200 に設定していたのです。
思い当たることあって、mtu を標準の1500に戻してみました。
すると、新しいkernelでもちゃんとamandaは動作します。
ジャンボフレームなんて設定しても、体感ではあまり変わらないし、そのためにネットワークに支障をきたすのでは、元も子もないので、ジャンボフレームを使わないことにしようと思います。
2008年04月05日
linux : 起動時に外付けHDDを認識させる
Fedora Core 6 のマシンを起動するときに、USBの外付けHDDをマウントする必要性が出てきた。
ディスクを起動時にマウントするには、/etc/fstab に
/dev/sda1 /mnt/usb ext3 defaults 0 0
と書けばいいのだが、これだけではだめ。
起動直後は、usb-storage というモジュールが読み込まれていないのである。だからシステムは /dev/sda1 を認識していない。
これを読み込むには、/etc/rc.d/rc.localなどに、
modprobe usb-storage
なんて書いておいてもいい。
だが、それだともう一度 mount -a などとしなければならない。
そこで、initrd ファイルを書き換えた。
まず、/boot/initrd ディレクトリ以下にinitrdイメージを展開。
# cd /boot
# mkdir initrd
# cd initrd
# zcat ../initrd-2.6.18-1.2798.fc6.img | cpio -i -c
展開されたファイルの中に init というファイルがある。
この中では必要なモジュールを次々と読み込んでいる箇所がある。
その最後に、
echo "Loading usb-storage.ko module"
insmod /lib/usb-storage.ko
と挿入。
もちろん ./lib ディレクトリには、usb-storage.koをコピーしておく。これは /lib/modules 以下から探してきた。
これをまた、initrdのイメージファイルにする。
# cd /boot/initrd
# find . | cpio --quiet -c -o | gzip -c > ../initrd-2.6.18.org.img
最後に、/boot/grub/grub.conf の、initrd コマンドに、ここで作成したファイル名を指定して再起動。
ディスクを起動時にマウントするには、/etc/fstab に
/dev/sda1 /mnt/usb ext3 defaults 0 0
と書けばいいのだが、これだけではだめ。
起動直後は、usb-storage というモジュールが読み込まれていないのである。だからシステムは /dev/sda1 を認識していない。
これを読み込むには、/etc/rc.d/rc.localなどに、
modprobe usb-storage
なんて書いておいてもいい。
だが、それだともう一度 mount -a などとしなければならない。
そこで、initrd ファイルを書き換えた。
まず、/boot/initrd ディレクトリ以下にinitrdイメージを展開。
# cd /boot
# mkdir initrd
# cd initrd
# zcat ../initrd-2.6.18-1.2798.fc6.img | cpio -i -c
展開されたファイルの中に init というファイルがある。
この中では必要なモジュールを次々と読み込んでいる箇所がある。
その最後に、
echo "Loading usb-storage.ko module"
insmod /lib/usb-storage.ko
と挿入。
もちろん ./lib ディレクトリには、usb-storage.koをコピーしておく。これは /lib/modules 以下から探してきた。
これをまた、initrdのイメージファイルにする。
# cd /boot/initrd
# find . | cpio --quiet -c -o | gzip -c > ../initrd-2.6.18.org.img
最後に、/boot/grub/grub.conf の、initrd コマンドに、ここで作成したファイル名を指定して再起動。
2008年03月27日
samba とか Active Directory とか
Fedora Core 6で動いているsamba に、Vista マシンからアクセスできなくなった。Xp や Windows 2000 からならアクセスできるのだが、Vista だとだめなのである。
うちには Windows 2000 Server も稼働していて、Active Directory を構成している。
fc6 の samba はこのWindows 2000 Server でユーザー認証してもらえるように、smb.conf の中で
Security = Domain
と設定していた。今まではこれでうまくいっていたのだが、何かのタイミングで突然アクセスできなくなったわけである。
あれこれとネットをさまよった情報によると、
Security = ADS
にしておけとのこと。
ちゃんとActive Directory に参加しろということなのである。
実際にそのようにしてみたら、Vistaからでもアクセスできるようになった。とりあえずよかった。
sambaをActive Directory に参加させるには、
こんなところやこんなところを参考にした。
うちには Windows 2000 Server も稼働していて、Active Directory を構成している。
fc6 の samba はこのWindows 2000 Server でユーザー認証してもらえるように、smb.conf の中で
Security = Domain
と設定していた。今まではこれでうまくいっていたのだが、何かのタイミングで突然アクセスできなくなったわけである。
あれこれとネットをさまよった情報によると、
Security = ADS
にしておけとのこと。
ちゃんとActive Directory に参加しろということなのである。
実際にそのようにしてみたら、Vistaからでもアクセスできるようになった。とりあえずよかった。
sambaをActive Directory に参加させるには、
こんなところやこんなところを参考にした。